Users are unable to check balance due to block explorer latency

Incident Report for Immutable

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 21:02 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 20:16 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 19:54 AEDT

Investigating

We are currently investigating an issue with the Immutable block explorer (explorer.immutable.com) that is preventing users from being able to check their balance through Immutable Play and Immutable Toolkit
Posted Mar 27, 2025 - 19:41 AEDT