Some Passport transactions are unable to finalise

Incident Report for Immutable

Resolved

We are pleased to inform you that the issue affecting Immutable Passport has been resolved. Our team has implemented a fix and verified that the service is operating normally.

Incident Start Time: 01/10/25 09:01:00
Incident Resolution Time: 01/10/25 10:58:00

We apologise for any disruption this may have caused and thank you for your understanding.
Posted Oct 01, 2025 - 11:07 AEST

Monitoring

Our team has implemented a fix for the issue and are continuing to monitor the system.

Severity Level: Low
Next Update: 10m

We apologise for any inconvenience this may cause and appreciate your patience.
Posted Oct 01, 2025 - 10:59 AEST

Identified

We are investigating an issue that is preventing some Passport transactions from finalising. The cause of the issue has been identified, and our team is working on mitigating the issue.

Severity Level: High
Next Update: 30m

We apologise for any inconvenience this may cause and appreciate your patience.
Posted Oct 01, 2025 - 10:05 AEST
This incident affected: Immutable Services (Passport).