Immutable X transactions via Passport failing
Incident Report for Immutable
Resolved
The issue affecting Passport transactions on Immutable X has been resolved. Our team has implemented a fix and verified that the service is operating normally.
Posted Sep 19, 2024 - 14:42 AEST
Investigating
We are currently investigating an issue impacting transfers via Passport on Immutable X

Our team is actively working on resolving this and will provide updates as soon as possible.
Posted Sep 19, 2024 - 13:43 AEST
This incident affected: Platform Services (Passport).