Immutable X Orderbook API timing out
Incident Report for Immutable
Resolved
The issue affecting the Immutable X Orderbook API has been resolved. The service is operating normally.
Posted Nov 21, 2024 - 13:36 AEDT
Investigating
Immutable X Orderbook functionality may be limited. We are investigating the issue.
Posted Nov 21, 2024 - 09:54 AEDT