Intermittent errors reported for minting on Echoes of Cryptalia

Incident Report for Immutable

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 07:00 AEDT

Identified

Echoes of Cryptalia users have experienced technical issues during their mint, which resulted in transaction failures for some players.

The Echoes of Cryptalia and Immutable teams are actively investigating the root cause alongside Magic engineers to ensure a thorough resolution. Our priority is to support impacted players and provide clarity as soon as possible.

We appreciate the patience of the community and will share further updates as soon as we have more information.
Posted Feb 18, 2025 - 00:25 AEDT
This incident affected: Platform Services (Passport).