Delays in minting API due to high load

Incident Report for Immutable

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 09:27 AEST

Identified

Due to ongoing and sustained minting load, the immutable API will returning pending for minted NFTs while the backlog clears. We will continue to update this statuspage as information is available
Posted Jun 05, 2025 - 00:14 AEST
This incident affected: Immutable zkEVM (Mainnet).