Incorrect network selected by Metamask when using Link
Incident Report for Immutable
Resolved
This issue is now resolved. Please ensure you are running the latest stable version of MetaMask which includes fixes for this issue.
Posted Sep 03, 2024 - 08:54 AEST
Identified
We have identified that MetaMask has enabled an experimental feature for users which is incompatible with Link. We are engaging with MetaMask on next steps.

The work around below is confirmed to resolve this issue for users. Please reach out to Immutable Support if you continue to have issues after attempting the work around.
Posted Aug 27, 2024 - 21:45 AEST
Investigating
We are investigating issues with Link not recognising the selected chain.

To work around this issue, users can turn off the "Select networks for each site" experimental feature in Metamask.

We are investigating options to fix this for all users.
Posted Aug 27, 2024 - 21:06 AEST
This incident affected: Immutable X (Immutable X Link).