Some users unable to claim perpetual rewards

Incident Report for Immutable

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 11:40 AEST

Investigating

We are currently investigating an issue impacting perpetual rewards that may be causing an issue for some users who are attempting to claim.

Our team is actively working on resolving this and will provide updates as soon as possible.

We apologise for any inconvenience this may cause and appreciate your patience.
Posted Jun 25, 2025 - 10:31 AEST
This incident affected: Platform Services (Immutable Play).