RPC timeouts resulting in failed Passport transactions

Incident Report for Immutable

Resolved

The issue affecting Passport has been resolved. Our team has implemented a fix and verified that the service is operating normally.

We apologise for any disruption this may have caused and thank you for your understanding.
Posted Mar 03, 2025 - 10:26 AEDT

Monitoring

Our team has implemented a fix for the issue and is continuing to monitor the system.
Posted Mar 03, 2025 - 10:21 AEDT

Investigating

We are currently investigating an issue impacting Passport transactions. In-game transactions may be failing at this time.

Our team is actively working on resolving this and will provide updates as soon as possible.

We apologise for any inconvenience this may cause and appreciate your patience.
Posted Mar 03, 2025 - 10:00 AEDT
This incident affected: Platform Services (Passport).