Immutable Play not showing ERC20 balances

Incident Report for Immutable

Resolved

The issue has now been resolved. ERC20 balances are correctly showing on Immutable Play.
Posted Aug 15, 2025 - 09:13 AEST

Investigating

We are investigating an issue with token balances not displaying correctly on Immutable Play.

While the investigation is ongoing, you can check token balances via Immutable Toolkit https://toolkit.immutable.com/balances/.
Posted Aug 15, 2025 - 03:57 AEST
This incident affected: Immutable Services (Immutable Play).