Users are unable to submit transactions using Passport Wallets

Incident Report for Immutable

Resolved

Passport Wallet transactions are fully functional.

Thank you for your patience while we worked through this issue with our provider Magic.
Posted Dec 03, 2025 - 13:35 AEDT

Monitoring

Magic have finished reverting their changes. We have observed a complete recovery with Passport Wallet transactions.
Posted Dec 03, 2025 - 13:04 AEDT

Identified

We have identified that a change made by Magic Labs is preventing Passport wallets from transacting.

Magic are working to revert their changes with restoration expected by 01:45 UTC.
Posted Dec 03, 2025 - 12:35 AEDT

Investigating

We are currently investigating an issue impacting Passport that may be causing issues when submitting transactions to Immutable zkEVM.

Our team is actively working on resolving this and will provide updates as soon as possible.
Posted Dec 03, 2025 - 12:28 AEDT
This incident affected: Immutable Services (Passport).