Possible delays in processing deposits and withdrawals on IMX.
Incident Report for Immutable
Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 10:40 AEST
Update
All delays in deposit visibility are now resolved.

We are continuing to monitor the delays in withdrawal processing.
Posted Aug 19, 2024 - 14:06 AEST
Monitoring
We are continuing to monitor the delay experienced by some withdrawals on IMX.

The expected processing time for a withdrawal is now 48 hours.

We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Aug 19, 2024 - 10:15 AEST
Investigating
We are experiencing some possible delays in processing deposits and withdrawals on IMX.
Posted Aug 17, 2024 - 12:53 AEST
This incident affected: Immutable X (Immutable X API).