Multiple services are unavailable

Incident Report for Immutable

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 17:24 AEDT

Monitoring

We have implemented a fix and are continuing to monitor.
Posted Dec 04, 2025 - 16:51 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Dec 04, 2025 - 16:12 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 04, 2025 - 16:05 AEDT

Investigating

We are currently investigating reports of numerous services being unavailable.
Posted Dec 04, 2025 - 15:15 AEDT
This incident affected: Immutable X (Immutable X API).