Passport Wallet operations failing on Immutable X

Incident Report for Immutable

Resolved

This incident is now resolved.
Posted Sep 04, 2024 - 15:25 AEST

Monitoring

New transactions are now accepted and we are closely monitoring the processing of the accumulated backlog. We apologise for the inconvenience.
Posted Sep 04, 2024 - 15:22 AEST

Identified

We have identified the root cause and are actively working towards remediation.
Posted Sep 04, 2024 - 15:18 AEST

Investigating

We are currently investigating an issue impacting Passport that may be causing issues transacting on Immutable X.

Our team is actively working on resolving this and will provide updates as soon as possible.
Posted Sep 04, 2024 - 15:14 AEST
This incident affected: Immutable X and Platform Services (Passport).